Настройка scikit-learn – ошибки numpy при импорте

Я пытаюсь настроить scikit-learn, но после установки numpy и scikit-learn (using pip) это то, что я получаю при попытке imort sklearn:

import sklearn RuntimeError: module compiled against API version 8 but this version of numpy is 7 Traceback (most recent call last): File "<stdin>", line 1, in <module> File "/usr/local/lib/python2.7/site-packages/sklearn/__init__.py", line 32, in <module> from .base import clone File "/usr/local/lib/python2.7/site-packages/sklearn/base.py", line 10, in <module> from scipy import sparse File "/Library/Python/2.7/site-packages/scipy-0.13.0.dev_c31f167_20130304-py2.7-macosx-10.8-intel.egg/scipy/sparse/__init__.py", line 182, in <module> from .csr import * File "/Library/Python/2.7/site-packages/scipy-0.13.0.dev_c31f167_20130304-py2.7-macosx-10.8-intel.egg/scipy/sparse/csr.py", line 15, in <module> from .sparsetools import csr_tocsc, csr_tobsr, csr_count_blocks, \ File "/Library/Python/2.7/site-packages/scipy-0.13.0.dev_c31f167_20130304-py2.7-macosx-10.8-intel.egg/scipy/sparse/sparsetools/__init__.py", line 5, in <module> from .csr import * File "/Library/Python/2.7/site-packages/scipy-0.13.0.dev_c31f167_20130304-py2.7-macosx-10.8-intel.egg/scipy/sparse/sparsetools/csr.py", line 26, in <module> _csr = swig_import_helper() File "/Library/Python/2.7/site-packages/scipy-0.13.0.dev_c31f167_20130304-py2.7-macosx-10.8-intel.egg/scipy/sparse/sparsetools/csr.py", line 22, in swig_import_helper _mod = imp.load_module('_csr', fp, pathname, description) ImportError: numpy.core.multiarray failed to import 

Пытался переустановить вещи без успеха

  • Не удалось установить Pygame с помощью пипса
  • Как установить python-dateutil в Windows?
  • Веб-сайт импорта Python не работает
  • Установка файла колеса
  • rpy2 установить на windows 7
  • ValueError: numpy.dtype имеет неправильный размер, попробуйте перекомпилировать
  • Как установить модули python без доступа root?
  • pip install pydot повышает значение SyntaxError
  • Установка файла колеса
  • Установка нескольких версий пакета с помощью pip
  • scikit-learn install failure / numpy not found / missing numpy headers
  • pip: как установить запрос git pull
  • One Solution collect form web for “Настройка scikit-learn – ошибки numpy при импорте”

    Глядя на эту проблему в github, похоже, что для нее может потребоваться определенная версия numpy – они использовали 1.7.0b2.

    Python - лучший язык программирования в мире.