Tag: pip

Как добавить virtualenv в путь

Я пытаюсь выяснить, почему мой virtualenv и / или virtualenv wrapper, установленный с использованием pip с использованием homebrew не могут быть найдены. Я думаю, это потому, что он не добавлен в мой PATH: $ which virtualenv $ а также: $ virtualenv someDir $ -bash: virtualenv: command not found Я установил pip с помощью homebrew , […]

как копировать модули из одного виртуального в другой

Возможно ли копировать модули python из одного виртуального в другой. Как это сделать?

Пакеты пиков не найдены – Пивоваренный Python

Запуск Python 2.7.3, установленный с HomeBrew, на Mac. Устанавливается несколько пакетов с использованием PIP, включая virtualenv. (Использование virtualenv в качестве примера, но NONE из пакетов работает.) Когда я пытаюсь запустить их в терминале, он не работает следующим образом: $ virtualenv venv –distribute -bash: virtualenv: command not found В качестве альтернативы: $ python virtualenv.py venv /usr/local/Cellar/python/2.7.3/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python: […]

Как установить lxml в Python 3.4 на компьютере с Windows

Я трачу часы на это. Я новичок в Python и не вижу, что такое решение. У меня есть Python 3.4 и вы хотите работать с .docx , для чего требуется lxml . Рабочий процесс, который я делал до сих пор, заключается в следующем: я перехожу на страницу установки пакета Python lxml , но мне сложно […]

PIP install не может найти ffi.h, даже если он распознает libffi

Я установил libffi на свой Linux-сервер, а также правильно установил PKG_CONFIG_PATH среды PKG_CONFIG_PATH в правильный каталог, так как pip распознает, что он установлен; однако при попытке установить pyOpenSSL, pip утверждает, что он не может найти файл 'ffi.h'. Я знаю и то, что ffi.h существует, а также его каталог, так как мне нужно закрыть этот разрыв […]

Если python-dev потребуется для установки pip

Я обнаружил, что у многих людей возникают проблемы с установкой пакетов python с помощью pip, поскольку python-dev не установлен. В основном, ошибка: fatal error: Python.h: No such file or directory Итак, вопрос: должен ли python-dev быть необходимой зависимостью от pip? Или это только проблема для определенных пакетов, которые устанавливаются вместе с pip, и если да, […]

python install module apiclient

Новый для python и пытается установить модуль «apiclient», так как мой ide pycharm не распознает этот импорт: from apiclient.discovery import build что я пробовал: pip apiclient скачайте вручную пакет из https://developers.google.com/api-client-library/python/start/installation#system-requirements, затем я извлек его в /Users/nirregev/anaconda/bin/google-api-python-client-1.5.0 и запускал это на моем mac terminal python setup.py install, но все же pycharm не распознает этот модуль. […]

Не удается получить PIL для правильной установки на Ubuntu 12.04

Я использую Ubuntu 12.04, и я в PIL-hell. Я пробовал каждое предложение, которое я могу найти в Интернете для способов установки PIL, но мне не повезло. Я знаю, что у меня есть всякая зависимость. Я пробовал все методы symlink. Я изменил файл setup.py, чтобы убедиться, что он находит правильные каталоги. Я также попытался построить источник […]

Нужна помощь в установке lxml на os x 10.7

Я изо всех сил from lxml import etree сделать from lxml import etree ( import lxml отлично работает, кстати). Ошибка: ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site- packages/lxml/etree.so, 2): Symbol not found: _htmlParseChunk Referenced from: /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/lxml/etree.so Expected in: flat namespace in /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/lxml/etree.so Я использовал pip для установки lxml и homebrew, чтобы переустановить libxml2 с правильной архитектурой (или так я думаю) […]

ImportError: нет модуля с именем extern

Я получаю эту ошибку при попытке установить любой пакет с помощью pip. У меня два экземпляра pip, один с Python 2.7 и другие с Python 3. Could not import setuptools which is required to install from a source distribution. Traceback (most recent call last): File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 375, in setup_py import setuptools # noqa File […]

Python - лучший язык программирования в мире.