Tag: pip

Ошибка установки пакета: невозможно импортировать имя 'unpack_url'

Я использую Python 3.4.1 64-бит на машине под Windows 8.1. В последнее время Пип вызывает проблемы, особенно эта ошибка: C:\Users\Charlie\Desktop>pip install wxPython_Phoenix-3.0.3.dev78341-cp34-none-w in_amd64.whl Traceback (most recent call last): File "C:\Python34\Scripts\pip-script.py", line 9, in <module> load_entry_point('Scipy-stack==14.8.27', 'console_scripts', 'pip')() File "C:\Python34\lib\site-packages\pkg_resources\__init__.py", line 519, in l oad_entry_point return get_distribution(dist).load_entry_point(group, name) File "C:\Python34\lib\site-packages\pkg_resources\__init__.py", line 2630, in load_entry_point return ep.load() […]

pip install -upgrade sqlalchemy дает максимальную глубину рекурсии

Я попробовал pip install –upgrade sqlalchemy , python2.7 setup.py install , а после удаления папки sqlalchemy в пакетах сайтов я попытался pip install sqlalchemy . Все они дают «RuntimeError: максимальная глубина рекурсии превышена в cmp». File "C:\Python27\lib\ntpath.py", line 200, in splitext return genericpath._splitext(p, sep, altsep, extsep) File "C:\Python27\lib\genericpath.py", line 102, in _splitext sepIndex = max(sepIndex, […]

Get pip для работы с git и github-хранилищем

Я пишу приложение python, которое зависит от другого, размещенного в репозитории github (никогда в pypi) по причинам развития. Давайте позвоним им: Приложение написано: AppA Приложение в github: AppB В приложении А setup.py выглядит так: # coding=utf-8 import sys try: from setuptools import setup, find_packages except ImportError: import distribute_setup distribute_setup.use_setuptools() from setuptools import setup, find_packages setup( […]

Не удается обновить Pip. Доступ запрещен. Зачем?

Я пытаюсь обновить pip на моем iMac, но я все время получаю отказ в разрешении на отказ. Я администратор, поэтому я не знаю, что я сделал неправильно. iMac:~ me$ pip install –upgrade pip You are using pip version 6.0.8, however version 7.1.2 is available. You should consider upgrading via the 'pip install –upgrade pip' command. […]

как установить PIL с поддержкой JPEG на малине pi?

Я попытался установить PIL на мой малиновый pi и прочитать файлы JPEG. Однако это не работает из коробки. Когда я запускаю следующее: sudo pip install pil Я получаю следующую ошибку, пытаясь открыть изображение: ""decoder jpeg not available"" При попытке установить все необходимые библиотеки JPEG я столкнулся с некоторыми ошибками, например: sudo apt-get install libjpeg E: […]

easy_install или pip как ограниченный пользователь?

Стандартный python distutils предоставляет опцию «–user», которая позволяет мне устанавливать пакет как ограниченный пользователь, например: python setup.py install –user Есть ли эквивалент для easy_install и pip ?

Как установить pip3 на мой Mac?

Я пытаюсь установить pip3, но мне не повезло. Кроме того, я попытался установить sudo, и это не сработало. Как мне установить pip3 на мой Mac? sudo easy_install pip3 Password: Searching for pip3 Reading https://pypi.python.org/simple/pip3/ Couldn't find index page for 'pip3' (maybe misspelled?) Scanning index of all packages (this may take a while) Reading https://pypi.python.org/simple/ No […]

Как я могу сделать требования к соблюдению Пиком?

Если я создам setup.py с помощью require, Pip не устанавливает мои зависимости. Вот мой setup.py: from distutils.core import setup setup(name='my_project', description="Just a test project", version="1.0", py_modules=['sample'], requires=['requests']) Я написал простую sample.py: import requests def get_example(): return requests.get("http://www.example.com") Затем я пытаюсь установить его: $ pip install -e . [15:39:10] Obtaining file:///tmp/example_pip Running setup.py egg_info for package […]

pip: как установить запрос git pull

Я хочу установить запрос git pull с помощью pip для тестирования в моем локальном virtualenv. Я хочу установить его непосредственно из github, не создавая локальный репозиторий git.

Pip не собирает пользовательский набор cmdclass

поэтому я нашел этот ответ на мой точный вопрос, но по какой-то причине он не работает: $ cat /tmp/testinstall/setup.py : from setuptools.command.install import install from setuptools import setup class verifying_install(install): def run(self): print "running…….." install.run(self) print "verifying…….." setup(name='test', version='1', py_modules=['test'], include_package_data=True, zip_safe=True, cmdclass={'install': verifying_install} ) Но тогда, даже если setup.py install работает :: ➜ /tmp/testinstall […]

Python - лучший язык программирования в мире.