Tag: pip

«Проверка сертификата SSL не удалась» с помощью pip для установки пакетов

Я пытаюсь установить пакет Scrapy (среди прочего) для python, используя pip. Я попытался выполнить установку с помощью python 3 и python 2, я установил / обновил setuptools следующим образом: $ pip3 install –upgrade setuptools , я попытался использовать –trusted-host так: $ pip3 install –trusted-host pypi.python.org Scrapy . Но я всегда получаю то же сообщение об […]

Ошибка создания uwsgi с помощью pip в виртуальной среде

Я получаю ошибки, когда пытаюсь установить uwsgi в своей виртуальной среде в моем Centos VPS. В конечном счете, я не могу установить uwsgi. Я использую : pip install uwsgi а также : pathtovirtualenv/bin/pip install uwsgi Я получаю следующий вывод на терминале: wwwthecanonworks@thecanonworks.com [~]# ~/thecanonworks/env/bin/pip install uwsgi Downloading/unpacking uwsgi Downloading uwsgi-2.0.8.tar.gz (775kB): 775kB downloaded Running setup.py […]

Ошибка импорта BeautifulSoup – Конфликт с версией Python

Я установил BeautifulSoup с командой: sudo easy_install BeautifulSoup4 Я получил сообщение: Searching for BeautifulSoup4 Best match: beautifulsoup4 4.1.3 Processing beautifulsoup4-4.1.3-py2.6.egg beautifulsoup4 4.1.3 is already the active version in easy-install.pth Using /Library/Python/2.6/site-packages/beautifulsoup4-4.1.3-py2.6.egg Processing dependencies for BeautifulSoup4 Finished processing dependencies for BeautifulSoup4 Я пытаюсь импортировать библиотеку BeautifulSoup. >>> from BeautifulSoup import BeautifulSoup Traceback (most recent call last): […]

Установка пипа для обоих питонов

Я новичок в pip, и я использую его для установки некоторого модуля в моей системе, скажем, pyglet, успешно. У меня есть 2 версии python, 2.7 и 3. Когда я использую python3, pyglet работает нормально, но в python2 он говорит, что модуль pyglet не найден. Как я могу установить pip на python2 и python3? Благодарю.

У Python есть решение для управления зависимостями версий?

У Python есть что-то похожее на apt или Maven, где в одном репозитории могут размещаться разные версии библиотеки, а не только в текущей версии? Например: папка «Мои site-packages » не группирует библиотеки по версии. Поэтому вместо: /Library/Python/2.7/site-packages/tox/1_2_3 У нас есть: /Library/Python/2.7/site-packages/tox … который предположительно содержит последнюю версию токсина, которая может или не может быть совместима […]

Борьба за установку пигтта с пипсом

Я пытаюсь установить pygtk, используя pip в Windows. Первоначально я получаю сообщение об ошибке «ERROR: Не удалось импортировать модуль dsextras: убедитесь, что вы установили pygobject». Поэтому, когда я пытаюсь установить pygobject, я получаю сообщение об ошибке «ERROR: Не удалось найти pkg-config: проверьте свою переменную среды PATH» Довольно новичок в Python, поэтому можно было сделать глупую […]

Ошибка с MySQLdb на OS X El Capitan

Я попытался импортировать MySQLdb в iPython и получил следующую ошибку. ImportError Traceback (most recent call last) <ipython-input-4-f5538763dbdb> in <module>() —-> 1 import MySQLdb as mdb 2 import sys /Users/user1/anaconda/lib/python2.7/site-packages/MySQLdb/__init__.py in <module>() 17 from MySQLdb.release import __version__, version_info, __author__ 18 —> 19 import _mysql 20 21 if version_info != _mysql.version_info: ImportError: dlopen(/Users/user1/anaconda/lib/python2.7/site-packages/_mysql.so, 2): Library not loaded: […]

Обновления pyOpenSSL и pandas с использованием «pip» завершаются с «TypeError: resolve () получили неожиданный аргумент ключевого слова« replace_conflicting »»

Когда я пытаюсь обновить или установить любую версию pandas или pyOpenSSL (с любым экземпляром sudo pip –[un]install|update [–no-use-wheel] [pandas|pyOpenSSL|xattr|stevedore] , используя pip 1.5 .4) Получаю: Command python setup.py egg_info failed with error code 1 in /private/tmp/pip_build_root/pandas Storing debug log for failure in /Users/Rax/Library/Logs/pip.log … TypeError: resolve() got an unexpected keyword argument 'replace_conflicting' Почему я получаю […]

Невозможно установить модули через pip на python 3.4

Я пытаюсь установить различные модули, которые мне нужно для запуска этого скрипта: https://github.com/austingandy/slack-evernote/blob/master/slackwriter.py Я работаю с Mac, а моя python –version : Python 3.4.3 :: Anaconda 2.3.0 (x86_64) И у меня для python -m pip –version : pip 8.0.2 from /Users/dhruv/anaconda/lib/python3.4/site-packages (python 3.4) Однако, например, когда я запускаю pip install evernote я получаю такие ошибки, […]

pip install с «ValueError: 'format» в конфликтах __slots__ с переменной класса "

При попытке установить панель progressbar пакета python на OSX El Capitan, я получаю следующую ошибку: Collecting progressbar Using cached progressbar-2.3.tar.gz Complete output from command python setup.py egg_info: Traceback (most recent call last): File "<string>", line 20, in <module> File "/private/var/folders/9s/b1jly7yd0jq639plvkzdvn4m0000gn/T/pip-build-xhfxywsw/progressbar/setup.py", line 5, in <module> import progressbar File "/private/var/folders/9s/b1jly7yd0jq639plvkzdvn4m0000gn/T/pip-build-xhfxywsw/progressbar/progressbar/__init__.py", line 59, in <module> from progressbar.widgets import […]

Python - лучший язык программирования в мире.