Установка python не может найти psycopg2 ImportError

Я вызываю psycopg2 с помощью

import psycopg2 

Я получаю std-ошибку

  • Команды выбора портов Macports
  • macports не помещал python_select в / opt / local / bin
  • Устранение неполадок Версия Python в Sublime Text2
  • Как выбрать: Macports выбрать python
  • Не удалось установить matplotlib на Mac OS X
  • Найдите пакет MacPorts?
  • ImportError: нет модуля с именем psycopg2

    Я установил свою копию с помощью macports, поэтому мне любопытно, почему это не сработает, потому что все зависимости также должны быть загружены. У меня нет опыта работы с Postgresql, ни с этим модулем, поэтому я не знаю, что может быть неправильным. Факт – это еще один проект, который я пытаюсь получить от него, поэтому, если бы я мог избежать использования этого, я бы это сделал. 🙂

    Я уверен, что postgresql установлен, но это мало связано с тем, что моя установка не может найти psycopg2. Любые внушители были бы оценены.

     $ which python 

    показывает

     /Library/Frameworks/Python.framework/Versions/Current/bin/python 

    а также

     $ python --version 

    показывает

     Python 2.7.3 -- EPD_free 7.3-2 (32-bit) 

    Мне не обязательно нужна версия EPD_free, но мне пришлось установить ее для (несколько) несвязанных причин.

  • Как установить библиотеку Python 'gevent' в Mac OS X Lion
  • Python: MySQLdb и «Библиотека не загружена: libmysqlclient.16.dylib»
  • psycopg2 на OSX: мне тоже нужно установить PostgreSQL?
  • Python не может импортировать
  • Каков наиболее совместимый способ установки модулей python на Mac?
  • Vim не скомпилируется с python на OS X
  • One Solution collect form web for “Установка python не может найти psycopg2 ImportError”

    MacPorts устанавливает собственную версию Python вместе с версией Apple. Вы можете управлять активной версией Python (той, которая запускается при вводе в python в командной строке или / usr / bin / env) с помощью команды port select . См. Этот вопрос .

    Python - лучший язык программирования в мире.